REST API | WPSSO Add-on

Popis

Enhances the WordPress REST API post, term, and user query results with an array of social and SEO meta tags, and Schema JSON-LD markup.

Includes a new head element in the WordPress REST API query result to provide an html, json, and parts array.

  • The html array includes the HTML formatted meta tags and Schema JSON-LD (aka LD+JSON) scripts, as they appear in the webpage head section.

  • The json array provides Schema JSON-LD (aka LD+JSON) scripts in their decoded format.

  • The parts array offers HTML meta tag attributes (aka „the parts“) as arrays, making it easier to find / use specific meta tag values.

There is no add-on settings page for this plugin — simply install and activate the plugin.

WPSSO Core Plugin Required

WPSSO REST API (aka WPSSO REST) is an add-on for the WPSSO Core plugin.

The WPSSO Schema JSON-LD Markup add-on is recommended to get the most complete meta tags and Schema JSON-LD markup for post, term, and user queries.

Recenze

Přečtěte si všechny 2 recenze

Autoři

REST API | WPSSO Add-on je otevřený software. Následující lidé přispěli k vývoji tohoto pluginu.

Spolupracovníci

Plugin „REST API | WPSSO Add-on“ byl přeložen do 2 jazyků. Děkujeme všem překladatelům za jejich pomoc.

Přeložte “REST API | WPSSO Add-on” do svého jazyka.

Zajímá vás vývoj?

Prohledejte kód, podívejte se do SVN repozitáře, nebo se přihlaste k odběru protokolu vývoje pomocí RSS.

Přehled změn

Version Numbering

Version components: {major}.{minor}.{bugfix}[-{stage}.{level}]

  • {major} = Major structural code changes / re-writes or incompatible API changes.
  • {minor} = New functionality was added or improved in a backwards-compatible manner.
  • {bugfix} = Backwards-compatible bug fixes or small improvements.
  • {stage}.{level} = Pre-production release: dev < a (alpha) < b (beta) < rc (release candidate).

Standard Version Repositories

Changelog / Release Notes

Version 2.2.0-dev.3 (2020/04/03)

  • New Features
    • None.
  • Improvements
    • None.
  • Bugfixes
    • None.
  • Developer Notes
    • Refactored WPSSO Core active and minimum version dependency checks.
  • Requires At Least
    • PHP v5.6.
    • WordPress v4.0.
    • WPSSO Core v6.27.2-dev.3.

Version 2.1.0 (2020/03/27)

  • New Features
    • None.
  • Improvements
    • Minor update for French translation strings.
  • Bugfixes
    • None.
  • Developer Notes
    • None.
  • Requires At Least
    • PHP v5.6.
    • WordPress v4.7.
    • WPSSO Core v6.27.1.