Plugin nebyl testován na 3 nejnovějších verzích WordPressu. Nemusí už být tedy podporován a u novějších verzí WordPressu může mít problémy s kompatibilitou a může být nestabilní.

Parsedown Party

Popis

This plugin lets you use Markdown for individual posts on a case-by-case basis. Markdown can be activated using a toggle in the post editor submit box. When enabled, it replaces the WordPress post editor with CodeMirror in Markdown mode.

Works on posts using the Classic Editor. Gutenberg is currently not supported.

Snímky obrazovky

  • Parsedown Party in the post editor.

Nejčastější dotazy

If I turn this on for a post, can I go back to HTML if I change my mind?

Yes.

Can I automatically enable Markdown for all new posts?

Yes. Add the following line to your theme’s functions.php (or another suitable place):

add_filter( 'parsedownparty_autoenable', '__return_true' );
Is this plugin compatible with Pressbooks?

Yes.

Does this plugin work with Gutenberg?

Not yet. It works on posts using the Classic Editor. The block editor is currently not supported.

I’m a software developer, how can I help?

This plugin follows Pressbooks coding standards and development happens on GitHub.

The philosophy behind this plugin is: Take a best of breed Markdown Parser, combine it with WordPress‘ built-in CodeMirror libraries, and let users write posts in Markdown. Things like two-pane WYSIWYG editors are out of scope for this particular plugin (the Preview button works fine.) The design goal is to modify WordPress Core as little as possible while providing decent Markdown support for content.

What about Gutenberg? Haven’t started yet. Tiny MDE looks like a good place to get ideas.

Recenze

Přečtěte si 1 recenzi

Autoři

Parsedown Party je otevřený software. Následující lidé přispěli k vývoji tohoto pluginu.

Spolupracovníci

Plugin „Parsedown Party“ byl přeložen do 1 jazyku. Děkujeme všem překladatelům za jejich pomoc.

Přeložte “Parsedown Party” do svého jazyka.

Zajímá vás vývoj?

Prohledejte kód, podívejte se do SVN repozitáře, nebo se přihlaste k odběru protokolu vývoje pomocí RSS.

Přehled změn

1.2.1

  • Compatibility with WordPress 5.3 (and Classic Editor)
  • Updated composer dependencies

1.2.0

  • Compatibility with WordPress 5.1 (and Classic Editor)
  • Fixed paragraphs following tables

1.1.1

  • Fix cache glitch when previewing.

1.1.0

  • When enabling Markdown on an existing post, convert HTML to Markdown.
  • Cache parsed content using transients.

1.0.2

  • Update Parsedown to version 1.7.1

1.0.1

  • Add parsedownparty_autoenable filter to allow Markdown to be enabled by default.

1.0.0

  • Initial release.